using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-zÀ-ÿ]{2,}([.-])?)+( ?(([A-zÀ-ÿ]){2,}([.-])?))* (([A-zÀ-ÿ]){2,}([.-])?)+$";
string input = @"xfbhc-xbfdfg fdhfdhdrhhdffh grgfdbdf ñÁ-ñÁ
dfgffsdfd-dfggsgsg sr. sfefsg
Roberto Jr.
Carlos-pablos Petrosyan jr.
carlos-pablos Petrosyan jr.
Rodrigo Jr. Ahora
Gabriel Ira rodrigez. jr.
Gabriel Ira rodr-igez. jr.
Ira Gabriel rodb nman-jnir ngor
Ira gabriel rodb nman-jnir. ngo
Gabriel Jr. Ira rodr-igez jr-
-------------------------------------------------------------
fdghdf dggdg dgdghdh dfff dgggddggdgh
Gabriel Ira rodr-igez. jr.
Gabriel Jr.. Ira rodr-igez. jr.
Gabriel.. Jr. Ira rodr-igez. jr.
rodrigo jr.. ahora
knlknllk k fgjnfn
hgh
hgghrhgfnf
jhdsbdhfbj
dfvdfvf sdvds ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}