package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-zÀ-ÿ]{2,}([.-])?)+( ?(([A-zÀ-ÿ]){2,}([.-])?))* (([A-zÀ-ÿ]){2,}([.-])?)+$`)
var str = `xfbhc-xbfdfg fdhfdhdrhhdffh grgfdbdf ñÁ-ñÁ
dfgffsdfd-dfggsgsg sr. sfefsg
Roberto Jr.
Carlos-pablos Petrosyan jr.
carlos-pablos Petrosyan jr.
Rodrigo Jr. Ahora
Gabriel Ira rodrigez. jr.
Gabriel Ira rodr-igez. jr.
Ira Gabriel rodb nman-jnir ngor
Ira gabriel rodb nman-jnir. ngo
Gabriel Jr. Ira rodr-igez jr-
-------------------------------------------------------------
fdghdf dggdg dgdghdh dfff dgggddggdgh
Gabriel Ira rodr-igez. jr.
Gabriel Jr.. Ira rodr-igez. jr.
Gabriel.. Jr. Ira rodr-igez. jr.
rodrigo jr.. ahora
knlknllk k fgjnfn
hgh
hgghrhgfnf
jhdsbdhfbj
dfvdfvf sdvds `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}