#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=_(?<!\S_))[a-zA-Z0-9]+\b"
Local $sString = "Calculate the _area of the _perfectRectangle object." & @CRLF & _
"" & @CRLF & _
"The _id and _age variables are both integers." & @CRLF & _
"" & @CRLF & _
"__invalidVariable _evenMoreInvalidVariable_ _validVariable" & @CRLF & _
"" & @CRLF & _
"_validVariable_test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")