#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<div>((?:(?!<div>).)*?)<\/div>"
Local $sString = "<div> foo <div> bar </div>" & @CRLF & _
"" & @CRLF & _
" <div> bar </div> baz </div>" & @CRLF & _
"" & @CRLF & _
"<div> foo <div> bar </div> baz </div>" & @CRLF & _
"" & @CRLF & _
"<div>< <span>Foo</span> ></div>" & @CRLF & _
"<div>< <span>Foo</span> v></div>" & @CRLF & _
"<div>< <span>Foo</span> iv></div>" & @CRLF & _
"<div>< <span>Foo</span> div></div>" & @CRLF & _
"<div>< <span>Foo</span> /div></div>" & @CRLF & _
"<div>< <span>Foo</span> </div></div>" & @CRLF & _
"<div><d <span>Foo</span> ></div>" & @CRLF & _
"<div><d <span>Foo</span> v></div>" & @CRLF & _
"<div><d <span>Foo</span> iv></div>" & @CRLF & _
"<div><d <span>Foo</span> div></div>" & @CRLF & _
"<div><d <span>Foo</span> /div></div>" & @CRLF & _
"<div><d <span>Foo</span> </div></div>" & @CRLF & _
"<div><di <span>Foo</span> ></div>" & @CRLF & _
"<div><di <span>Foo</span> v></div>" & @CRLF & _
"<div><di <span>Foo</span> iv></div>" & @CRLF & _
"<div><di <span>Foo</span> div></div>" & @CRLF & _
"<div><di <span>Foo</span> /div></div>" & @CRLF & _
"<div><di <span>Foo</span> </div></div>" & @CRLF & _
"<div><div <span>Foo</span> ></div>" & @CRLF & _
"<div><div <span>Foo</span> v></div>" & @CRLF & _
"<div><div <span>Foo</span> iv></div>" & @CRLF & _
"<div><div <span>Foo</span> div></div>" & @CRLF & _
"<div><div <span>Foo</span> /div></div>" & @CRLF & _
"<div><div <span>Foo</span> </div></div>" & @CRLF & _
"<div><div> <span>Foo</span> ></div>" & @CRLF & _
"<div><div> <span>Foo</span> v></div>" & @CRLF & _
"<div><div> <span>Foo</span> iv></div>" & @CRLF & _
"<div><div> <span>Foo</span> div></div>" & @CRLF & _
"<div><div> <span>Foo</span> /div></div>" & @CRLF & _
"<div><div> <span>Foo</span> </div></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")