using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div>((?:(?!<div>).)*?)<\/div>";
string input = @"<div> foo <div> bar </div>
<div> bar </div> baz </div>
<div> foo <div> bar </div> baz </div>
<div>< <span>Foo</span> ></div>
<div>< <span>Foo</span> v></div>
<div>< <span>Foo</span> iv></div>
<div>< <span>Foo</span> div></div>
<div>< <span>Foo</span> /div></div>
<div>< <span>Foo</span> </div></div>
<div><d <span>Foo</span> ></div>
<div><d <span>Foo</span> v></div>
<div><d <span>Foo</span> iv></div>
<div><d <span>Foo</span> div></div>
<div><d <span>Foo</span> /div></div>
<div><d <span>Foo</span> </div></div>
<div><di <span>Foo</span> ></div>
<div><di <span>Foo</span> v></div>
<div><di <span>Foo</span> iv></div>
<div><di <span>Foo</span> div></div>
<div><di <span>Foo</span> /div></div>
<div><di <span>Foo</span> </div></div>
<div><div <span>Foo</span> ></div>
<div><div <span>Foo</span> v></div>
<div><div <span>Foo</span> iv></div>
<div><div <span>Foo</span> div></div>
<div><div <span>Foo</span> /div></div>
<div><div <span>Foo</span> </div></div>
<div><div> <span>Foo</span> ></div>
<div><div> <span>Foo</span> v></div>
<div><div> <span>Foo</span> iv></div>
<div><div> <span>Foo</span> div></div>
<div><div> <span>Foo</span> /div></div>
<div><div> <span>Foo</span> </div></div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}