import Foundation
let pattern = #"<div>((?:(?!<div>).)*?)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div> foo <div> bar </div>
<div> bar </div> baz </div>
<div> foo <div> bar </div> baz </div>
<div>< <span>Foo</span> ></div>
<div>< <span>Foo</span> v></div>
<div>< <span>Foo</span> iv></div>
<div>< <span>Foo</span> div></div>
<div>< <span>Foo</span> /div></div>
<div>< <span>Foo</span> </div></div>
<div><d <span>Foo</span> ></div>
<div><d <span>Foo</span> v></div>
<div><d <span>Foo</span> iv></div>
<div><d <span>Foo</span> div></div>
<div><d <span>Foo</span> /div></div>
<div><d <span>Foo</span> </div></div>
<div><di <span>Foo</span> ></div>
<div><di <span>Foo</span> v></div>
<div><di <span>Foo</span> iv></div>
<div><di <span>Foo</span> div></div>
<div><di <span>Foo</span> /div></div>
<div><di <span>Foo</span> </div></div>
<div><div <span>Foo</span> ></div>
<div><div <span>Foo</span> v></div>
<div><div <span>Foo</span> iv></div>
<div><div <span>Foo</span> div></div>
<div><div <span>Foo</span> /div></div>
<div><div <span>Foo</span> </div></div>
<div><div> <span>Foo</span> ></div>
<div><div> <span>Foo</span> v></div>
<div><div> <span>Foo</span> iv></div>
<div><div> <span>Foo</span> div></div>
<div><div> <span>Foo</span> /div></div>
<div><div> <span>Foo</span> </div></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)