#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[-a-zA-Z.0-9]*@[-a-zA-Z0-9]*\.[a-z]{3}"
Local $sString = "CoreyMSchafer@gmail.com" & @CRLF & _
"corey.schafer@university.edu" & @CRLF & _
"corey-321-schafer@my-work.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")