#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$"
Local $sString = "1010101+101" & @CRLF & _
"10101*111" & @CRLF & _
"00011/0" & @CRLF & _
"10-010000" & @CRLF & _
"11" & @CRLF & _
"100101" & @CRLF & _
"1010101+-101" & @CRLF & _
"1992-1231+" & @CRLF & _
"1009/3100" & @CRLF & _
"120120120" & @CRLF & _
"0001+" & @CRLF & _
"10-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")