using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$";
string input = @"1010101+101
10101*111
00011/0
10-010000
11
100101
1010101+-101
1992-1231+
1009/3100
120120120
0001+
10-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}