package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$`)
var str = `1010101+101
10101*111
00011/0
10-010000
11
100101
1010101+-101
1992-1231+
1009/3100
120120120
0001+
10-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}