re = /^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$/m
str = '1010101+101
10101*111
00011/0
10-010000
11
100101
1010101+-101
1992-1231+
1009/3100
120120120
0001+
10-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end