// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-1]+)(?:([+|\-|\/|*])([0-1]+))*$").unwrap();
let string = "1010101+101
10101*111
00011/0
10-010000
11
100101
1010101+-101
1992-1231+
1009/3100
120120120
0001+
10-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}