import Foundation
let pattern = #"(^ \* @([a-z]+).*)(?=\r?\n^ \* @(?!\2))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/**
* Get Data
*
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
* @param null|ProductInterface $product
* @return string
* @throws LocalizedException
* @throws NoSuchEntityException
* @consumes something
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n *"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)