package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9\.]+)([A-Za-z]+)`)
var str = `1.785K
10MEG
999.1V`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}