re = /(?<![^,])(?:(?:25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(?:25[0-5]|2[0-4]\d|[01]?\d\d?)(?![^,])/m
str = '255.255.255.255,255.255.255.256,260.255.255.255'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end