# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\\/=]+=.*//gm;t' <<< "file_paths
my-file-path/wefw/wefw/wef/wfweof=wefonwe/wfewoi=weoif/
my-file-path/wefw/wef/ef=wefonwe/wfewoi=weoif/
my-file-path/wef/wfe/wefw/wef/ef=wefonwe/wfewoi=weoif/"