const regex = /\\\\|\\\*|\*\*((?:\\\\|\\\*\*|\*(?!\*)|[\S\s])*?)\*\*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\\\\\|\\\\\\*|\\*\\*((?:\\\\\\\\|\\\\\\*\\*|\\*(?!\\*)|[\\S\\s])*?)\\*\\*', 'g')
const str = `**bold**
**foo * bar **
**foo \\** bar**
**foo \\\\** bar** **
\\**bold** **
\\\\**bold**
`;
const subst = `$0\t\t\t<strong>$1<strong>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);