using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<field2>\w+)\\(?<field3>[^\/]+)$";
string input = @"sourcefield=/var/log/bash_history/localuser/DOMAIN\first.last.domain
sourcefield=/var/log/bash_history/DOMAIN\first.last.domain/DOMAIN\first.last.domain";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}