#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\{\{Term\|([^|]+)\|content=([a-z]+)}}}"
Local $sString = "{{Term|AbCdEf|content=abcdef}}" & @CRLF & _
"{{Term|AbCdEf|content=abcdef}}" & @CRLF & _
"{{Term|ABC|content=abc}}" & @CRLF & _
"" & @CRLF & _
"Term|AbCdEf|content=abcdef" & @CRLF & _
"{{Term|AbCdEf|content=abcde}}" & @CRLF & _
"{{Term|AbCdE|content=abcdef}}" & @CRLF & _
"{{Term|AbCdEf|content=aBcdef}}" & @CRLF & _
"{{Term|content=}}"
Local $sSubst = "{{Term|$2}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)