import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/topic\\/(?:.+-)*(\\d+)";
final String string = "/post/cho-minh-hoi-voi-kien-thuc-ve-cc-va-sql-o-truong-dai-hoc-da-du-de-thuc-tap-chua-vay-moi-nguoi-minh-2131321-nghe-may-nguoi-da-tot-nghiep-noi-la-luc-di-lam-nguoi-ta-ko-dung-nhung-kien-thuc-trong-truong-dai-1321321321";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}