using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d$|^\d\s\d$|^\d\s\d\s\d$|^\d\s\d\s\d\s\d$";
string input = @"0
0 1
0 1 2
0 1 2 3
0
0 00
0 12 1 0
0
0
0
00
0 1 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}