import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d$|^\\d\\s\\d$|^\\d\\s\\d\\s\\d$|^\\d\\s\\d\\s\\d\\s\\d$";
final String string = "0\n"
+ "0 1\n"
+ "0 1 2\n"
+ "0 1 2 3\n\n"
+ "0 \n"
+ "0 00\n"
+ "0 12 1 0\n"
+ " 0 \n"
+ " 0\n"
+ "0 \n"
+ "00\n"
+ "0 1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}