using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+\s?(years?|months?|weeks?|days?|hours?|minutes?|min|mins?|seconds?|sec|secs?|y|M|w|d|h|m|s)\s?)+$";
string input = @"5 weeks 50m";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}