import re
regex = re.compile(r"^https?:\/\/t\.me\/\w{5,}$", flags=re.MULTILINE)
test_str = ("https://t.me/httd1\n"
"https://t.me/botfather\n"
"https://t.me/telegrambrasil\n"
"http://t.me/telegrambrasil\n"
"https://t.m/telegrambrasil\n"
"https://t.me/tele\n"
"http;/t.me\\llllll\n"
"text message https://t.me/telegrambrasil")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")