re = /^https?:\/\/t\.me\/\w{5,}$/m
str = 'https://t.me/httd1
https://t.me/botfather
https://t.me/telegrambrasil
http://t.me/telegrambrasil
https://t.m/telegrambrasil
https://t.me/tele
http;/t.me\\llllll
text message https://t.me/telegrambrasil'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end