package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):values: (.*)(\n.*)*:modal_name: (.*)`)
var str = `:values: T
:asdfasdfa
:asdf
:asdfad
:modal_name: Operational_Segment_Weekly
`
var substitution = "$3=$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}