package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b((?:\w+(?:'\w+)?)(?:-(?:\w+(?:'\w+)?))*)\b`)
var str = `aguardaram-se
guarda-chuva
gota-d'água
d'água
água
teste
-
a_b
123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}