const regex = /\n[ \t]+for /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\n[ \\t]+for ', 'gm')
const str = `T="topic 1"
for xxx@xxx.com
T="topic 2"
for yyy@yyy.com`;
const subst = ` | `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);