$re = '/\n[ \t]+for /m';
$str = 'T="topic 1"
for xxx@xxx.com
T="topic 2"
for yyy@yyy.com';
$subst = " | ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;