#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)value\s+(one|two|three)\s+=\s+([0-9]+)"
Local $sString = "Statistics indicator:0x222235" & @CRLF & _
"" & @CRLF & _
"number of records = 3" & @CRLF & _
"" & @CRLF & _
"records[0]" & @CRLF & _
"" & @CRLF & _
"value one = 2" & @CRLF & _
"" & @CRLF & _
"value two = 5" & @CRLF & _
"" & @CRLF & _
"blocks = 2" & @CRLF & _
"" & @CRLF & _
"block[0] {" & @CRLF & _
"" & @CRLF & _
"some irrelevant data...." & @CRLF & _
"" & @CRLF & _
"value three = 4 bytes" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"block[1]{" & @CRLF & _
"" & @CRLF & _
"some irrelevant data..." & @CRLF & _
"" & @CRLF & _
"value three = 6 bytes" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"records[1]" & @CRLF & _
"" & @CRLF & _
"value one = 3" & @CRLF & _
"" & @CRLF & _
"value two = 5" & @CRLF & _
"" & @CRLF & _
"blocks = 1" & @CRLF & _
"" & @CRLF & _
"block[0] {" & @CRLF & _
"" & @CRLF & _
"some irrelevant data...." & @CRLF & _
"" & @CRLF & _
"value three = 4 bytes" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"records[2]" & @CRLF & _
"" & @CRLF & _
"value one = 7" & @CRLF & _
"" & @CRLF & _
"value two = 6" & @CRLF & _
"" & @CRLF & _
"blocks = 2" & @CRLF & _
"" & @CRLF & _
"block[0] {" & @CRLF & _
"" & @CRLF & _
"some irrelevant data...." & @CRLF & _
"" & @CRLF & _
"value three = 3 bytes" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"block[1]{" & @CRLF & _
"" & @CRLF & _
"some irrelevant data..." & @CRLF & _
"" & @CRLF & _
"value three = 4 bytes" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Statistics indicator:0x135256" & @CRLF & _
"" & @CRLF & _
"number of records = 2" & @CRLF & _
"" & @CRLF & _
"records[0]" & @CRLF & _
"" & @CRLF & _
"value one = 4" & @CRLF & _
"" & @CRLF & _
"value two = 8" & @CRLF & _
"" & @CRLF & _
"blocks = 1" & @CRLF & _
"" & @CRLF & _
"block[0] {" & @CRLF & _
"" & @CRLF & _
"some irrelevant data...." & @CRLF & _
"" & @CRLF & _
"value three = 6 bytes" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"records[1]" & @CRLF & _
"" & @CRLF & _
"value one = 3" & @CRLF & _
"" & @CRLF & _
"value two = 5" & @CRLF & _
"" & @CRLF & _
"blocks = 1" & @CRLF & _
"" & @CRLF & _
"block[0] {" & @CRLF & _
"" & @CRLF & _
"some irrelevant data...." & @CRLF & _
"" & @CRLF & _
"value three = 3 bytes" & @CRLF & _
"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")