# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"value\s+(one|two|three)\s+=\s+([0-9]+)"
test_str = ("Statistics indicator:0x222235\n\n"
"number of records = 3\n\n"
"records[0]\n\n"
"value one = 2\n\n"
"value two = 5\n\n"
"blocks = 2\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 4 bytes\n\n"
"}\n\n"
"block[1]{\n\n"
"some irrelevant data...\n\n"
"value three = 6 bytes\n\n"
"}\n\n"
"records[1]\n\n"
"value one = 3\n\n"
"value two = 5\n\n"
"blocks = 1\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 4 bytes\n\n"
"}\n\n"
"records[2]\n\n"
"value one = 7\n\n"
"value two = 6\n\n"
"blocks = 2\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 3 bytes\n\n"
"}\n\n"
"block[1]{\n\n"
"some irrelevant data...\n\n"
"value three = 4 bytes\n\n"
"}\n\n"
"Statistics indicator:0x135256\n\n"
"number of records = 2\n\n"
"records[0]\n\n"
"value one = 4\n\n"
"value two = 8\n\n"
"blocks = 1\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 6 bytes\n\n"
"}\n\n"
"records[1]\n\n"
"value one = 3\n\n"
"value two = 5\n\n"
"blocks = 1\n\n"
"block[0] {\n\n"
"some irrelevant data....\n\n"
"value three = 3 bytes\n\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.