re = /value\s+(one|two|three)\s+=\s+([0-9]+)/m
str = 'Statistics indicator:0x222235
number of records = 3
records[0]
value one = 2
value two = 5
blocks = 2
block[0] {
some irrelevant data....
value three = 4 bytes
}
block[1]{
some irrelevant data...
value three = 6 bytes
}
records[1]
value one = 3
value two = 5
blocks = 1
block[0] {
some irrelevant data....
value three = 4 bytes
}
records[2]
value one = 7
value two = 6
blocks = 2
block[0] {
some irrelevant data....
value three = 3 bytes
}
block[1]{
some irrelevant data...
value three = 4 bytes
}
Statistics indicator:0x135256
number of records = 2
records[0]
value one = 4
value two = 8
blocks = 1
block[0] {
some irrelevant data....
value three = 6 bytes
}
records[1]
value one = 3
value two = 5
blocks = 1
block[0] {
some irrelevant data....
value three = 3 bytes
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end