using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[-?\d+[.]\d+,-?\d+[.]\d+\]";
string input = @"[10.6302565,-74.9131161]
[-10.6302565,-74.9131161]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}