$re = '/\[-?\d+[.]\d+,-?\d+[.]\d+\]/';
$str = '[10.6302565,-74.9131161]
[-10.6302565,-74.9131161]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);