// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})").unwrap();
let string = "39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018";
let substitution = "$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}