import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S*) && (\\1[\\.\\[]).+";
final String string = "// Optional chaining for Javascript is now in stage 4:\n"
+ "// https://github.com/tc39/proposal-optional-chaining\n"
+ "// WARNING: This is NOT native to JS yet, so you will need to use a babel plugin to convert it:\n"
+ "// https://babeljs.io/docs/en/babel-plugin-proposal-optional-chaining\n\n"
+ "// Which means you can use this regex to find where in your codebase you can replace this:\n"
+ "user && user.profile && user.profile.email\n"
+ "// with this:\n"
+ "user?.profile?.email\n\n"
+ "// these should match because they have an object variable being accessed multiple times with a dot or opening bracket\n"
+ "data && data[query] && data[query].items && data[query].items.length > 0\n"
+ "const street = user.address && user.address.street;\n\n"
+ "// this should not match because they're not accessing the same object\n"
+ "data && form.user && api.authenticated";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}