package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)S\[[^]]*\](*SKIP)(*FAIL)|\((?:[^()]|(?R))*\)`)
var str = `I am a (test) S[ but i am (not catched)], catch (me (if you (()(())) can))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}