#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)de([\-_][A-Z]{2})*\Z"
Local $sString = "de" & @CRLF & _
"de-DE" & @CRLF & _
"de_DE" & @CRLF & _
"de_CH" & @CRLF & _
"de-CH" & @CRLF & _
"dd-WR" & @CRLF & _
"de-LONGWRONG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")