using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"de([\-_][A-Z]{2})*\Z";
string input = @"de
de-DE
de_DE
de_CH
de-CH
dd-WR
de-LONGWRONG";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}