// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)de([\-_][A-Z]{2})*\Z").unwrap();
let string = "de
de-DE
de_DE
de_CH
de-CH
dd-WR
de-LONGWRONG";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}