re = /@import (url\(\"?)?(url\()?(\")?(.*?)(?(1)\")+(?(2)\))+(?(3)\");
/m
str = '@import url(\'https://meyerweb.com/eric/tools/css/reset/reset200802.css\');
'
subst = '$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result