#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*Page"
Local $sString = "A_File1_Page1" & @CRLF & _
"A_File1_Page2" & @CRLF & _
"" & @CRLF & _
"A_File2_Page1" & @CRLF & _
"A_File2_Page2" & @CRLF & _
"A_File2_Page3" & @CRLF & _
"" & @CRLF & _
"B_File1_Page1" & @CRLF & _
"B_File1_Page2" & @CRLF & _
"B_File1_Page3" & @CRLF & _
"" & @CRLF & _
"B_File2_Page1" & @CRLF & _
"B_File2_Page2" & @CRLF & _
"B_File2_Page3" & @CRLF & _
"B_File2_Page4" & @CRLF & _
"" & @CRLF & _
"C_File1_Page1" & @CRLF & _
"C_File1_Page2" & @CRLF & _
"C_File1_Page3" & @CRLF & _
"C_File1_Page4" & @CRLF & _
"C_File1_Page5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")