$re = '/Projekt *\K[\d ]*\d/m';
$str = 'Projekt123
Projekt 123
Projekt 12 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);