using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table\b.*?\bclass\s*=\s*(['""]).*?\btest\b.*?\1.+?<\/table>";
string input = @"<table class=""test"">
<tr>
<td>bla bla bla</td>
</tr>
</table>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}