$re = '/<table\b.*?\bclass\s*=\s*([\'"]).*?\btest\b.*?\1.+?<\/table>/';
$str = '<table class="test">
<tr>
<td>bla bla bla</td>
</tr>
</table>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);