#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<table\b.*?\bclass\s*=\s*(['"]).*?\btest\b.*?\1.+?<\/table>"
Local $sString = "<table><tr><td><span class="test">bla bla bla</span></td></tr></table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")