using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<table\b.*?\bclass\s*=\s*(['""]).*?\btest\b.*?\1.+?<\/table>";
string input = @"<table><tr><td><span class=""test"">bla bla bla</span></td></tr></table>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}