import re
regex = re.compile(r"<table\b.*?\bclass\s*=\s*(['\"]).*?\btest\b.*?\1.+?<\/table>")
test_str = "<table><tr><td><span class=\"test\">bla bla bla</span></td></tr></table>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")