import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table\\b.*?\\bclass\\s*=\\s*(['\"]).*?\\btest\\b.*?\\1.+?<\\/table>";
final String string = "<table class=\"test\">\n"
+ "<tr>\n"
+ "<td>bla bla bla</td>\n"
+ "</tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}