$re = '~<(span).*?(/\1)>~';
$str = ';decreasing\'>1</a> <span class=\'active\'>2</span><a href=\'F;search&
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);